Flash přijímače R9 MM-OTA

Uživatelský avatar
LSoft
Příspěvky: 31
Registrován: ned 15. pro 2019 8:37:51

Flash přijímače R9 MM-OTA

Příspěvek od LSoft » sob 21. bře 2020 8:57:50

Zdravím,
zkouším flashnout tento přijímač pomocí OTA funkce přes vysílač Taranis Plus 2019 SE.
Postupuji podle návodu přijímače. V adresáři FIRMWARE vysílače vyberu soubor s FW, zadám "Flash receiver OTA", objeví se hláška "Waiting for Rx" a rádio začne pípat, že čeká na přijímač. Pak zapnu přijímač a konec. Hláška "Waiting for Rx" zmizí, rádio pípá dál, ovládání je mrtvé, lze se jenom posouvat v menu mezi soubory, tlačítka rádia nefungují, rádio lze jenom vypnout. Hláška "Select Rx", která by se měla objevit podle návodu, se neobjeví.
Co může být prosím špatně?
Btw, zkoušel jsem to flashnout i přes Horus X10 Express, ale tam vůbec není volba "Flash receiver OTA"...

Uživatelský avatar
LSoft
Příspěvky: 31
Registrován: ned 15. pro 2019 8:37:51

Re: Flash přijímače R9 MM-OTA

Příspěvek od LSoft » sob 21. bře 2020 13:07:11

Tak už je to vyřešeno. Stačilo flashnout FW vysílače na verzi 2.3.5 a pro jistotu jsem ještě nahrál nový FW 1.2.0 do přijímače i do Tx modulu R9M 2019.
Vše funguje. :)

Uživatelský avatar
LSoft
Příspěvky: 31
Registrován: ned 15. pro 2019 8:37:51

Re: Flash přijímače R9 MM-OTA

Příspěvek od LSoft » pon 13. dub 2020 9:35:45

Tak jsem včera zkusil nahrát do přijímače FW 1.3.0 přes OTA. Kliknul jsem v Horusovi "Flash receiver OTA" a nestalo se nic. Zajímavé. Tak jsem si říkal: to bude jako posledně, je potřeba nový OpenTX v rádiu. Tak jsem přehrál 2.3.5 na 2.3.7 a ejhle, volba "Flash receiver OTA" z rádia zmizela úplně... :D
Tak jsem zapátral a zjistil jsem, že volbu "Flash receiver OTA" vyvojáři z verze 2.3.7 vypustili, protože tahle funkce prý nějak narušovala obsluhování SD karty v rádiu. Škoda. Snad se to v další verzi opraví a zase to tam vrátí.
Tak jsem v koptéře udělal to, co jsem původně dělat nechtěl (kvůli spolehlivosti). Rozdělil jsem GND, Vcc a S.Port kabely od přijímače a vložil mezi ně konektor, abych byl připraven na "absence" funkce "Flash receiver OTA" a mohl přijímač flashovat přes servokabel :)
Jinak jsem byl příjemně překvapen, že po změně FW jak v přijímači tak i v R9M modulu nebylo potřeba párovat znovu přijímač. Nevím, jestli je tahle vlastnost přítomna už delší dobu, nicméně jsem si toho všiml až teď :lol:

BANE
Příspěvky: 30
Registrován: úte 07. kvě 2019 4:50:49

Re: Flash přijímače R9 MM-OTA

Příspěvek od BANE » úte 14. dub 2020 18:20:33

No paráda zrovna jsem to obědnal abych právě mohl použít tu OTA funkci a ono se stane toto :D no třeba to bude jiné s 9d ale asi ne...

BANE
Příspěvky: 30
Registrován: úte 07. kvě 2019 4:50:49

Re: Flash přijímače R9 MM-OTA

Příspěvek od BANE » stř 15. dub 2020 22:24:25

Tak ted mam problem a nevim jestli mam vadny prijimac a nebo neco delam spatne. Mam radio 9D+2019 v nem openTX 2.3.5 a modul R9M2019, ktery jsem ted hodil na access 1.3.0. Chtel jsem udelat flesh prijimace pres OTA a tak jsem to paroval podle navodu, ale nepovedlo se. Registrace OK a prejmenoval jsem si ho teda na R9MM (bylo Hello). Bind vse ok, ale na konci sviti cervena a ne zelena. Normalne to najde R9MM a tak to dam bind OK vse super, ale sviti cervena na prijimaci. Zkousim teda flash OTA a zase najde R9MM a tak ho beru napise ze tam je v1.1.1 a jestli to chcu jakoze prepsat, tak davam ano a naskoci nejaky problem se zapisem. Dobre dam flash pres s.port klasika a zase problem se zapisem jak v1.2.0, tak i v1.3.0. Uz fakt nevim co dal, nesparuje se to a prijimac nejde ani aktualizovat na posledni access.

EDIT: tak nakonec se povedl flash na 1.3.0 mel jsem spatne pripnuty s.port na prijimac. Neni to ale bez problemu. Porad jsou velke propady RSSI a netusim kde je problem. Zkousel jsem vymenit antenu a nepomohlo to. Zkusim jeste zitra ho zapajet do koptery, jestli neni problem s proudem, protoze tam to bude OK a uvidime, jestli se bude porad stracet a nebo ne.

EDIT2: napajel jsem to do koptery a vse funguje perfektně no asi mi přestal jít hebekl z Číny na kterém testuji přijímače omg. Zdálo se jakoby se rychle zapínal a vypínal a proto to nefungovalo.

Odpovědět